Encriptaremos certificados que pronto serán inválidos en teléfonos Android obsoletos

Si bien todo el mundo habla de actualizaciones de software en la superficie de Internet, algo está a punto de caducar en segundo plano, lo que podría eliminar pronto de Internet a los usuarios obsoletos de Android.

Vamos a cifrar, una autoridad de certificación gratuita que sirve a más del 30% de los dominios web del mundo con sus certificados TLS, su asociación con IdenTrust expirará, lo que hará que los teléfonos Android obsoletos sean inútiles pronto.

Los teléfonos Android que ejecutan la versión 7.1 o anterior están en riesgo

Los usuarios a los que les gusta navegar pueden notar el ícono de candado verde junto al dominio. Esto significa que la conexión entre el dispositivo del usuario y el dominio de acceso está encriptada y protegida durante toda la sesión. Esto es importante porque todos los detalles confidenciales ingresados ​​en la página del dominio no deben ser vistos por nadie.

Para hacer que estas conexiones sean seguras, hay organizaciones como Let’s Encrypt, que comenzó hace unos cinco años y se asoció con IdenTrust, una autoridad de certificación (CA), para firmar sus certificados raíz, autenticando así la conexión.

Encriptaremos aplicado para instalar su Raíz ISRG X1 certificado en la mayoría de los sistemas operativos como macOS, Android, Windows, Linux, etc., verificado por IdenTrust’s Raíz DST X3 fuente.

Y como la asociación entre los dos está a punto de expirar en septiembre del próximo año, Let’s Encrypt dice que los dispositivos que usen su certificado raíz serán firmados por cualquier CA más adelante. Esto hace que todos los dominios web, casi 30% de los dominios del mundo, inaccesible desde los navegadores de los usuarios. Let’s Encrypt mencionó que los dispositivos que se ejecutan en la versión 7.1 de Android y anteriores no serán compatibles en ese momento.

Aunque ahora puede funcionar de forma independiente con su propio certificado raíz, solo se admitirán los dispositivos más recientes (Android 7.2 y superior).

También mencionó una solución para usar el navegador Mozilla Firefox, que tiene sus propios certificados raíz instalados cuando está configurado y es compatible con Android 5.0 y versiones posteriores.

Artículo relacionado